Bug reports (Spoilers ahoy!)

All things Desktop Dungeons

Re: Bug reports (Spoilers ahoy!)

Postby dislekcia on Mon Nov 05, 2018 4:06 pm

tchernobog wrote:Hello! I have a strange bug in my recently started game.

I am attempting to complete Deep Freeze in Eastern Tundra as a monk, and I chose a Halfling monk.

For preparation, I've used a shield as a default item, and a fine sword as a locker item (though I think this also happened with a spoon).

Then I went around trying to kill level 2 creatures with the character. The game showed it would take 2-3 or more hits to kill it. Which is all fine. My damage values were lower than their total hp, so it makes sense.

However, my character was not only one shotting these creatures, they also gave 0 XP. Mobs that would one shot me would continue to do so, but I was able to kill level 2 and I think even level 3 creatures while my character was level 1, and he would remain level 1 due to not getting xp.

Did I do something wrong or is this a big ol' bug? :o


Could you please provide a video of this happening? I have no idea how that might have been possible in the game... Are you running the mod or otherwise editing the game itself?
User avatar
dislekcia
 
Posts: 2305
Joined: Fri Mar 25, 2011 5:58 pm
Location: Cape Town, South Africa

Re: Bug reports (Spoilers ahoy!)

Postby tchernobog on Mon Nov 05, 2018 4:32 pm

dislekcia wrote:
tchernobog wrote:Hello! I have a strange bug in my recently started game.

I am attempting to complete Deep Freeze in Eastern Tundra as a monk, and I chose a Halfling monk.

For preparation, I've used a shield as a default item, and a fine sword as a locker item (though I think this also happened with a spoon).

Then I went around trying to kill level 2 creatures with the character. The game showed it would take 2-3 or more hits to kill it. Which is all fine. My damage values were lower than their total hp, so it makes sense.

However, my character was not only one shotting these creatures, they also gave 0 XP. Mobs that would one shot me would continue to do so, but I was able to kill level 2 and I think even level 3 creatures while my character was level 1, and he would remain level 1 due to not getting xp.

Did I do something wrong or is this a big ol' bug? :o


Could you please provide a video of this happening? I have no idea how that might have been possible in the game... Are you running the mod or otherwise editing the game itself?


Sure! And this is unmodded and unedited, I am using the steam version of the game on desktop.

post edit: I forgot to include that I was also using the Taurog Shrine in my preparation, but to my (admittedly limited) knowledge, this shouldn't cause this issue.

https://youtu.be/JZQahJB2JMs
tchernobog
 
Posts: 3
Joined: Sat Nov 03, 2018 11:21 am

Re: Bug reports (Spoilers ahoy!)

Postby shade_of_ox on Mon Nov 05, 2018 8:59 pm

You did something wrong. If you look at the monsters you are fighting, they all have the Cowardly trait. This is because you prepared Taurog, if you read the text that describes what prepping Taurog actually does, it says that all enemies become Cowardly. Cowardly enemies run away when struck. If you explored a tile behind the enemy (there's a little animation showing the enemy "running" if you look closely) you will see that the enemy is still there, and has taken damage from your hit.
shade_of_ox
 
Posts: 396
Joined: Tue Jan 09, 2018 5:42 pm

Re: Bug reports (Spoilers ahoy!)

Postby tchernobog on Mon Nov 05, 2018 10:06 pm

shade_of_ox wrote:You did something wrong. If you look at the monsters you are fighting, they all have the Cowardly trait. This is because you prepared Taurog, if you read the text that describes what prepping Taurog actually does, it says that all enemies become Cowardly. Cowardly enemies run away when struck. If you explored a tile behind the enemy (there's a little animation showing the enemy "running" if you look closely) you will see that the enemy is still there, and has taken damage from your hit.


Oh, derp. I could've sworn I'd seen some just explode but I realize now they're hiding in the black. Thanks!
tchernobog
 
Posts: 3
Joined: Sat Nov 03, 2018 11:21 am

Re: Bug reports (Spoilers ahoy!)

Postby AvovA17 on Thu Dec 27, 2018 11:06 pm

Many dialogs that should be modal (the one you get if you press ESC during a run or the one you get in the wizard sub aka 1 for 2 potions) are not: pressing a hot key for a glyph activates it. For example, try pressing "1" with a transmuter.
AvovA17
 
Posts: 330
Joined: Tue Dec 26, 2017 5:38 pm

Re: Bug reports (Spoilers ahoy!)

Postby dislekcia on Wed Jan 02, 2019 10:22 am

AvovA17 wrote:Many dialogs that should be modal (the one you get if you press ESC during a run or the one you get in the wizard sub aka 1 for 2 potions) are not: pressing a hot key for a glyph activates it. For example, try pressing "1" with a transmuter.


Good catch, thanks! I've logged this, dunno when I'll get time to have someone work on the game again though... Maybe a full UI overhaul if loads of people start buying the game again :lol:
User avatar
dislekcia
 
Posts: 2305
Joined: Fri Mar 25, 2011 5:58 pm
Location: Cape Town, South Africa

Re: Bug reports (Spoilers ahoy!)

Postby AvovA17 on Thu Jan 03, 2019 7:41 am

Hey, my first ever crash of DD:
https://i.imgur.com/fEWPvsv.jpg

happened on a dungeon restart. I quit via the dungeon entrance and pressed restart.
AvovA17
 
Posts: 330
Joined: Tue Dec 26, 2017 5:38 pm

Re: Bug reports (Spoilers ahoy!)

Postby srid on Thu Jan 03, 2019 10:51 am

That tends to happen... And it happens a bit more in the EE, but we try to keep it low.
Out of curiosity, which dungeon was it?
We made an expansion and it is awesome. Really, you should check it out, especially if you're looking for some extra challenge.

Download over at ddmod.weebly.com!
User avatar
srid
 
Posts: 254
Joined: Sun Jan 07, 2018 8:46 pm

Re: Bug reports (Spoilers ahoy!)

Postby AvovA17 on Thu Jan 03, 2019 2:27 pm

srid wrote:That tends to happen... And it happens a bit more in the EE, but we try to keep it low.
Out of curiosity, which dungeon was it?


VGT
AvovA17
 
Posts: 330
Joined: Tue Dec 26, 2017 5:38 pm

Re: Bug reports (Spoilers ahoy!)

Postby AvovA17 on Thu Jan 10, 2019 12:11 am

The servers are down hard, as usual. For the last 20 minutes, I either cannot connect at all, or just the cloud sync works, but no DERP.

PS Finally I was able to connect 14 min past the daily cutoff time. Luckily I played it yesterday.


PPS: 47 min past the cutoff, it still keeps disconnecting.
AvovA17
 
Posts: 330
Joined: Tue Dec 26, 2017 5:38 pm

PreviousNext

Return to Desktop Dungeons

Who is online

Users browsing this forum: No registered users and 7 guests

cron